Investigating an issue...
Incident Report for Validis
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 19:54 UTC
Update
We are continuing to investigate this issue.
Posted Mar 12, 2020 - 19:53 UTC
Investigating
We are investigating an issue with our support ticket system. We recommend using our help site or contacting us by phone.
Posted Mar 12, 2020 - 18:56 UTC