Validis CA: Degraded Report Load Time

Incident Report for Validis

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 16:45 UTC

Monitoring

A fix has been implemented to address the issue. We will continue to monitor the system for stability.
Posted Feb 05, 2026 - 13:11 UTC

Investigating

We are currently aware of an issue where some users are affected with reports loading slowly.

Our technical team are investigating as a matter of urgency. We will continue to provide you updates via this status page.

We apologise for any inconvenience caused.
Posted Feb 05, 2026 - 10:31 UTC
This incident affected: Validis Platform (Validis CA).