We are currently investigating
Incident Report for Validis
Resolved
This incident has been resolved.
Posted Jan 24, 2020 - 09:30 UTC
Investigating
Our technical team are currently investigating availability issues for customer portals on DataShare US.

We will provide another update once we have identified the cause and are working on a fix.
Posted Jan 23, 2020 - 17:56 UTC