Validis UK: Validis Support

Incident Report for Validis

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 16:38 UTC

Monitoring

Following our investigation, the emails affected by this issue have now been released and delivery should begin to resume.

We are continuing to monitor closely to confirm that email delivery to support@validis.com has been fully restored, and will post a further update.

If you still need to reach the Validis Support Team while we confirm this, please continue to raise a ticket via our help center: https://support.validis.com/hc/en-gb/requests/new
Posted Aug 05, 2026 - 12:10 UTC

Investigating

We are aware of an issue that is preventing some emails sent to support@validis.com from being received.

Emails may be rejected or returned to the sender. Our team is investigating and working to restore normal delivery.

If you need to reach the Validis Support Team while this is ongoing, please raise a ticket directly to our help center via the link below.
https://support.validis.com/hc/en-gb/requests/new

We apologise for any inconvenience.
Posted Aug 05, 2026 - 11:53 UTC
This incident affected: Developer & Support Tools (Validis Help Centre).