Email Delivery Issues
Incident Report for Validis
Postmortem

Starting at 5:00 EST on 20 Aug 2018 - the DataShare Reseller platform in the United States issues with email delivery has been resolved.

Posted Jul 18, 2019 - 11:41 UTC

Resolved
DataShare Reseller platform in the United States is experiencing email delivery issues across all portals.
Posted Aug 18, 2018 - 13:00 UTC