Validis: Client portal timeout

Incident Report for Validis

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 08:50 UTC

Monitoring

A fix has been successfully deployed to address the issue. We are currently monitoring system performance to ensure stability.
Posted Oct 17, 2025 - 16:46 UTC

Identified

We’ve identified the issue and our team is actively working on implementing a fix.

We appreciate your patience and will continue to provide updates via this status page as we make progress toward full resolution.
Posted Oct 16, 2025 - 17:25 UTC

Investigating

We are currently aware of an issue where some users are being logged out of the portal due to low timeout.

Our technical team is currently investigating this as an urgent priority.

Apologies for the inconvenience, we will continue to provide you updates via this status page.
Posted Oct 16, 2025 - 13:18 UTC
This incident affected: Validis Platform (Validis UK, Validis US).