A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 16:03 UTC
Investigating
We’re currently aware of an issue preventing users from accessing Validis UK. Our technical team is currently investigating this as an urgent priority.
Apologies for the inconvenience, we will continue to provide you updates via this status page.
Posted Oct 08, 2025 - 15:21 UTC
This incident affected: Validis Platform (Validis UK).